frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Alert: This site is migrating to our new home at https://forums.intel.com/s/topic/0TO0P000000PqZDWA0/intel-neural-compute-sticks. Please visit us there!

NCSDK Installation Improvements: We Want Your Feedback!

2»

Comments

  • yyx
    edited July 2018 Vote Up0Vote Down

    @PINTO
    Thanks a lot.
    I have tried to export the PYTHONPATH to my bashrc. But it doesn't seems to work.
    I've solved this problem.
    I might because there are other caffe installed in my computer and I've installed pycaffe in it.
    After I delete the caffe folder previously installed. It runs well.
    Thank you

  • Hi, I am having trouble getting the NCSDK2 to compile on my Tinkerboard:
    https://tinkerboarding.co.uk/forum/thread-1714.html
    The instructions here are helping but its still failing to install. It seems to really struggle with Cython and scikit-image packages etc.

  • NCSDK : 2.05.00.02
    OS : Ubuntu Studio/Mate 16.04 & 18.04 ( on latest raspian it worked fine.. without adjustments )

    I had these three issues with 2.05.00.02

    1 Agundirected

    undefined symbol: Agundirected
    ImportError: /usr/local/lib/python3.5/dist-packages/pygraphviz/_graphviz.cpython-35m-x86_64-linux-gnu.so: undefined symbol: Agundirected

    sudo pip uninstall pygraphviz -y
    sudo pip3 uninstall pygraphviz -y
    sudo pip2 uninstall pygraphviz -y
    sudo rm -rf /usr/local/lib/python3.5/dist-packages/pygraphviz
    sudo rm -rf /usr/local/lib/python2.7/dist-packages/pygraphviz
    sudo pip3 install pygraphviz --install-option="--include-path=/usr/include/graphviz" --install-option="--library-path=/usr/lib/graphviz/"

    2 ** mvNCCompile Fails** - Illegal instruction

    sudo pip uninstall tensorflow
    sudo pip3 uninstall tensorflow
    sudo pip3 install tensorflow==1.5

    3 QObject
    QObject::moveToThread: Current thread (0x1ccfc50) is not the object's thread (0x1e09470).
    solution : install 3.4.2 from source ncappzoo2/apps/video_objects_threaded/install-opencv-from_source.sh

    /JB

  • Hello,

    As requested after the installation, I give here a feedback of how it went... I must say I am using Linux Mint (based om Ubuntu, and I most of the time have no compatibility problem except bypass the manufacturer verification based on the OS). Nevertheless, it has been quite a pain to install this, although it seemed rather easy in the first place. Moreover, I really doubt the problems I had came from the distro.

    • For a reason I do not understand, the "git clone" command for caffe did not work (an error about tls handshake) and I had to download the repository maually and copy it in the right folder. I also doubt the proxy is a problem since I did clone an other repository on the same day without any problem.
    • There is a test in the .bashrc file to look for a line looking like "export PYTHONPATH=", which did NOT exist in my bashrc and threw a fatal error instead of simply adding this line somewhere

    These are the two only errors I remember.

  • Installing with python virtual environments creates /opt/movidius/ under the root user with limited access to the main user. Once the virtual environment is active, the main user doesn't have permission to install things with pip install due to permission denied. Sudo pip install also does not run in the virtual environment and instead tries to install in the OS level python version.

    chown -R : /opt/movidius/ solves the problem but it should use the main user by default.

  • When will linux 18.04 distro be supported?????????????????????????????????????????????

  • it seems that the legacy ncsdk works on Linux disto 18.04 ....

  • I installed ncs v2.08 just right now, I used "make install", and I got "install complete". But when I used a command "mvNCCompile" , it told me "illegal instruction(core dumped)" , finally I find python3 had not install tensorflow, when it fix, ncsdk can work. So ncsdk just use python3?

  • I tried to install it using make api and it failed, because nobody at Intel supports the SDK! No merging of PRs, no answering issues, nothing! Shocking support.

    When Google releases their competitive product I'm going to switch, since the support cannot be worse than NOTHING which is what Intel provides right now.

  • How to improve the install ?

    In the version I downloaded (l_openvino_toolkit_p_2018.4.420.tgz) on to the Ubuntu 16.04 LTS I followed the instructions on this page : https://software.intel.com/en-us/neural-compute-stick/get-started which were good. To improve things I would,

    1. Make sure people go to the web page for install instructions.
    2. Advise people to ignore the warning text during the install scripts.
    3. Replace the "make -r8 " in the install script with "make". The "make -r8 " crashed my machine.
    4. Also the install script didn't create the directory alias correctly for the following types of commands (cd ~/intel/computer_vision_sdk) which I fixed by hand
  • Bought a neural compute stick back in July. Install removed cuda and corrupted QT and who knows what else. Movidius never responded to my support requests. No my laptop can no longer run cuda and anything that runs QT. We develop robotic products and the software needs to be tightly integrated not containerized. Docker, etc. is a cope out for crappy software.

  • edited June 2018 Vote Up-1Vote Down

    I would suggest to support Ubuntu 18.04

Sign In or Register to comment.