frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Alert: This site is migrating to our new home at https://forums.intel.com/s/topic/0TO0P000000PqZDWA0/intel-neural-compute-sticks. Please visit us there!

NCS SDK Virtual machine support

Hi Team,
I have install sdk in ubuntu16.04.2 in Virtualbox 5.1.22, but unfortunately, the usb port can not work, it show as below:
user@user-VirtualBox:~/workspace/Fathom_01_07_07/bin$ make example01
echo "example01 - GoogleNet profiling"
example01 - GoogleNet profiling
python3 ./mvNCProfile.pyc data/googlenet.prototxt -s 12
mvNCProfile v02.00, Copyright @ Movidius Ltd 2016

****** WARNING: using empty weights ******
[Error 7] Toolkit Error: USB Failure. Code: Error opening device
any advice is appriciate. Thanks

Comments

  • 29 Comments sorted by Votes Date Added
  • So - the VM guest OS acts just like Ubuntu or what not running on actual hardware, with respect to things like permissions, paths, import of libraries and links and so on. You can have all these issues on Linux running directly on hardware, they are not related to VM operations. "Caffe import error" would have to do with paths and permissions within the Ubuntu system. That's most likely a python path issue. I tend to use virtualenv to isolate my different working installations from each other (like neon vs. caffe) since they all like to have different python stuff. Occasionally, I forget to activate the virtualenv from the shell window. But there again, this is just ordinary linux and python stuff, unrelated to VM use.

    You should make sure that Caffe and especially pycaffe are installed and functional before proceeding with the rest of the NCS installation. Building and installing Caffe is not always easy and there's some confusion about installing and building that in the Caffe instructions and community. But not related using a VM.

    I have run into some occasional issues with USB 3.0 and NCS with some hubs and hosts. As a first step to debugging the issue, try connecting some other USB 2.0 and USB 3.0 devices to your VM and see that they are working properly, such as a USB storage stick, card reader, web cam. If those work, you can be reasonably sure your VM is working.

    I might suggest simply plugging the NCS into a powered USB 2.0 hub and see how it works with the VM. As I have found some USB3.0 hubs and hosts, cables can be tricky with the NCS. USB 2 seems quite reliable though.

    I have successfully run NCS under both Parallels (OSX) and VMWare with Ubuntu 16.04. I just started with a clean Ubuntu image, get that installed, configure with sufficient number of cores and memory in the VM and just proceed with a normal installation and update of Ubuntu, make sure it works right, then proceed with the pre-requisites and installation of NCS. It didn't require any unusual steps to make work.

  • @bing,wu@movidius.com please see @georgievm_cms 's comment about virtual machine support - https://ncsforum.movidius.com/discussion/comment/197/#Comment_197. Issues related to reliable USB connection over Virtual machines is out of our control, so we recommend that you use the NCS with a machine running Ubuntu 16.04 natively. Please also refer "What platforms does the Neural Compute Stick work on?" in https://ncsforum.movidius.com/discussion/100/product-faq

  • It depends on the VM - I have had success running NCS in a guest Ubuntu 16.04 hosted in Parallels on MacOS X. The specifics of setting up USB depend on the particular VM you're running. I've run other similar enviroments in VM Ware with good results. Virtual Box tends to take some configuration steps with USB, but I haven't used it very much.

    1. VirtualBox requires an extension pack for proper USB connections.
    2. If the guest machine has VirtualBox guest editions installed from the distro, you will need to remove them and install the guest additions ISO file that ships with the VirtualBox host platform.

    Yeah, you'll have some performance limitations, but if you install the Extension pack in the host and the right guest additions in the guest it should work with a supported VirtualBox host.

  • Hi @LarrySB ... I am running vmware workstation on MacOS X. I have the guest extensions installed ..

    It is connected through an USB 3 controller, but I keep getting this error:

    [Error 7] Toolkit Error: USB Failure. Code: Error opening device

    What did you configure to make it work?

  • "Error opening device" seems like a permissions problem. I did "sudo make example 01" and it moves on to the next step.

    Unfortunately, after a bit of a delay, I now get a message "Caffe import error". I'm running Ubuntu 16.04 LTS using VMWare Fusion on OSX 10.12.6 Sierra. I saw "caffe import error" messages during the SDK installation when I forgot to follow the instructions to close the terminal window and open a new one. Following that instruction solved the problem for the SDK installation, but it's not helping for running the examples.

  • Also, if the NCS is open and the software crashes or hangs in the midst of accessing it, disconnect the NCS and reconnect it. If that doesn't clear it up, you may need to unplug the NCS reboot Linux and try again. This happens on hardware linux as well. Working with the C toolkit, I have had a crash in my code, which seems to leave Linux USB ports hanging until a reboot.

  • I went and got a physical computer, ran through the same setup process that I had done on VMWare Fusion, and everything worked just fine. There's no "Caffe Import Error" message. So for me, at least, it goes back to the original recommendation in this thread: use physical hardware.

  • @frogman glad to know you have the SDK up and running. Have fun building inference applications with the NCS!


    iamintel

  • I just wanted to provide another data point.

    I received Caffe Import Errors too.

    I was using Ubuntu 16.04 LTS (fresh install) running in a Proxmox VM. Proxmox was running on a Dell R410 server.

  • edited August 2017 Vote Up0Vote Down

    It looks like it is the USB2 - USB3 switch that NCS is doing is confusing VirtualBox. I was able to run the examples on an OSX host by using a (bus powered) USB2 HUB, VirtualBox extensions & by configuring a USB Device Filter in the VM configuration (then reboot the guest). Then 1. manually select Devices->USB->Movidus Ltd... in the VirtualBox menu and 2. run make example01

    To run another example repeat (i.e. manually select the USB device in the menu again). This is not very convenient.. I can confirm it works seamlessly with Parallels and a USB HUB.

  • I installed Ubuntu 16.04 on Virtualbox . Everything works BUT after running any example on the compute stick it seems to disconnect the device at the end of the script. You just have to go to Device->USB and re select the Moviduis compute stick.

  • Here is a perl script to run in the host which will reconnect the Movidius stick to the VirtualBox VM when it gets disconnected.

  • Hi @LarrySB,

    I'm running with the same trouble using VMware Fusion 7.1.3 on Mac OSX.

    I wonder if you could share with us which version of VMware are you using.

    Thanks,

  • edited August 2017 Vote Up0Vote Down

    For VirtualBox on OSX the instructions by @ramana.rachakonda work perfectly. No need for a reconnect script either. Thx!

  • Finally I was able to make my NCS works under VMware Fusion 7.1.1 + OSX.

    The trick is:
    1. Configure VMWare USB Port to be 3.0
    2. Connect a USB 2.0 HUB to your OSX computer
    3. Connect your NCS to the USB hub.

    The same trick works with VirtualBox (https://ncsforum.movidius.com/discussion/140/mac-os-x).

  • edited September 2017 Vote Up0Vote Down

    I accidentally started a separate thread for the same issue here: https://ncsforum.movidius.com/discussion/212/installation-under-virtualbox#latest
    For what it's worth, I've had no luck getting this to work via VirtualBox 5.1.26 under Windows 10 even with a USB2.0, but I haven't tried a powered hub yet.
    Will follow up on this thread rather than the other one.

  • Funny enough I too am seeing a similar issue but not in a VM. I'm not sure what to do.

  • Technically speaking, the front ports on my workstation are connected to an internal USB 2.0 hub on the motherboard. Why isn't that good enough?

    I'd really, really like to get this to work with my existing hardware. I don't think that is too much to ask.

  • Hi, I am in the process of bringing up the Movidius NCS on SkullCanyon running Ubuntu16.04. While running example01, I get a error in transferring data to USB. While running example02 and example03, I get the message [Error 25] Myraid Error: "This software supports Myraid2 revision C silicon only".
    Inspired by the above posts, I have tried both USB2.0 and USB3.0.
    Is there anything wrong in my setup?
    -Thanks,
    Sujay

  • I am getting the same error on a non-VM environment on a Dell Latitude Laptop running Ubuntu 16.04.
    The only thing it is a Dual-Boot - either Windows 10 or Ubuntu

  • @Harsh Thanks for reporting this. A dual boot machine should not have any affect on the NCS. However, if you are referring to the error posted by the TS, I just want you to know that it is a known issue and it is currently being worked on at the moment. Thank you for your patience.

  • Thanks for the update @Tome_at_Intel ! Is there going to be a release to take care of this issue soon?

  • I just got an NCS and started downloading and installing all the software this morning. When I try "make example01" I get the same error as noted above "[Error 7] Toolkit Error: USB Failure. Code: Error opening device. The device shows up in the "dmesg" output. I am using a Dell Latitude 7240 with Ubuntu installed on the bare metal. No VM. Hopefully this gets solved quickly.

  • @janiamatmovidius Thank you for reporting this. I appreciate your patience while we work on a fix for this issue. I encourage all users to report any problems/wanted features that are encountered to this forum along with any technical specifics, so that we can be made aware of any issues, be able to reproduce the problem and issue a fix. Rest assured that we are listening to everyone and working towards a release. Thank you.

  • For those interested in using the NCS with a VM, the 1.09.00 release of the ncsdk on github now supports Virtual Machines per the instructions here: NCS VM configurations

  • I have created a vagrantfile script for virtualbox + guest extensions that works well:
    https://github.com/hughdbrown/movidius

    I only just saw @neal_at_intel 's VM docs so I don't have both USB configurations added.

  • I got it working on VMWare by opening Settings -> USB & Bluetooth -> Advanced -> USB Compatiblity (set to USB 3.0). The VM has to be powered off while doing this. Now it builds!

Sign In or Register to comment.