frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

New MVNCAPI is not working on RPi 3

After upgrading from V1 to V2, the new sample code is not working and I am getting this error:

pi@raspberrypi:~/face-recognition-model $ python main.py 
Starting Age/Gender detector
E: [         0] dispatcherEventReceive:200      dispatcherEventReceive() Read failed -1

^CSegmentation fault
pi@raspberrypi:~/face-recognition-model $

The script had frozen, and I had to press CTRL+C to close this script.

Do I have to upgrade the firmware of the NCS? If so, how can I do it?
Otherwise, is there any way to debug it?

Cheers.

Comments

  • 2 Comments sorted by Votes Date Added
  • @scarlyon You don't need to upgrade the firmware of the NCS device. I don't recognize the sample code you are referring to above: face-recognition-model, but the Caffe Age and Gender models should be working with NCSDK v2. Try running some of the included NCSDK 2 examples and see if they work for you.

  • Hi, I am trying to perform inference using a Tiny Yolo v2 and I am experiencing the same dispatcherEventReceive:200 error:

    I: [ 0] ncGraphQueueInference:3048 trigger start

    I: [ 0] ncGraphQueueInference:3145 trigger end

    E: [ 0] dispatcherEventReceive:200 dispatcherEventReceive() Read failed -4

    Were you able to find a solution?

    I am running Movidius in an Intel NUC D54250WYKH with Ubuntu 16.04 installed.

Sign In or Register to comment.