frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Procedure for "make examples" NCSDK v2.05.00.02 RaspberryPi3(Raspbian Stretch) / Ubuntu16.04

Share procedures that NCSDK 2.05.00.02 was successfully "make examples" to RaspberryPi3 / Ubuntu16.04.
I am happy if it will be helpful to everyone.
After implementation, I have only tested the limited scope that I need.
If you can do, I would like to tell you the results of your run test.

■ Notes
 Intel's informal procedures.
 Tensorflow 1.8.0 is not officially supported by Intel.
 No responsibility can be incurred no matter what happens.
 Please take responsibility for your actions.
 The NCSDK version to be installed is "v2.05.00.02".
 Successful July 12, 2018

■ Installation sequence

$ cd ~
$ wget https://github.com/google/protobuf/releases/download/v3.5.1/protobuf-all-3.5.1.tar.gz
$ tar -zxvf protobuf-all-3.5.1.tar.gz
$ cd protobuf-3.5.1
$ ./configure
$ sudo make -j1
$ sudo make install
$ cd python
$ export LD_LIBRARY_PATH=../src/.libs
$ python3 setup.py build --cpp_implementation 
$ python3 setup.py test --cpp_implementation
$ sudo python3 setup.py install --cpp_implementation
$ sudo ldconfig
$ protoc --version

$ wget https://github.com/lhelontra/tensorflow-on-arm/releases/download/v1.8.0/tensorflow-1.8.0-cp35-none-linux_armv7l.whl
$ sudo pip3 install tensorflow-1.8.0-cp35-none-linux_armv7l.whl
$ rm tensorflow-1.8.0-cp35-none-linux_armv7l.whl

$ cd ncsdk
$ make examples -j1

■ Problem
 Tensorflow 1.7.0 is always "make error" when building InceptionV3. (symbol undefined ...)
 Tensorflow 1.7.0's github also had a similar issue.
 Tensorflow 1.7.0 seems to be unstable.

Sign In or Register to comment.