frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Raspberry Pi 3 B+ : Full SDK install or API only?

Hello!

I'm thinking of installing the full version of the latest SDK release on my Raspberry Pi, but have read in multiple places that it is easier and quicker to install the API only, and do all development on a PC in an Ubuntu environment.

This makes sense, but I just wanted to double check that this was the correct way forwards? I've already wasted a lot of time trying to get the Examples working with a full SDK install on the Pi, and would like to make some progress ;)

Best Regards
Mark

Comments

  • 6 Comments sorted by Votes Date Added
  • "make api" in the ncsdk directory resulted in a fatal error:

    /home/pi/ncsdk/api/src/common/components/XLink/pc/usb_boot.c:38:20: fatal error: libusb.h: No such file or catalog
    #include <libusb.h>

    Any tips? Do I need to manually install the dependancies here?

  • Hello!

    You should install the development package for the version of the library you are using.
    E.g. if you are using libusb-1.0.0, then you should install libusb-1.0-0-dev.

    Regards,
    Marcin

  • @MarkWest1972 You should be able to do API only mode and full NCSDK install on a Raspberry Pi 3 B+ if you are using Raspian Stretch. If you are using the latest NCSDK, make sure to install cython3 using pip3 first, then do a make install. The install process on a Pi can take a long time and if it crashes, you may need to pull the plug and continue the installation using make install again. The reason it takes a long time is because it needs to build Caffe and OpenCV.

  • OK, thanks! I'm heading to the mountains for a week now, but will try again when I get back!

  • @Tome_at_Intel Does that mean, increasing swap size is preferred also for api-only mode installation, similar to full sdk installation?

  • Hi @sreerag_ibtl

    I have done the API-only installation on my RPI3 and did not need to increase swapfile size for a successful installation. However, it is recommended you do so just in case.

    Regards,
    Sahira

Sign In or Register to comment.