frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Read failed -1 when running my NCSDK ver2 updated image classifier

Hi I recently installed the NCSDK2 on my ubuntu 16.04 VM with a windows 10 host. I was trying to run the image_classifier.py example in the ncappzoo so I modified the APIs to the new ver 2 ones and tried running the file using the command 'python3 image_classifier.py' but I see that I get these messages and nothing happens

E:[ 0] dispatcherEventReceive:200 dispatcherEventReceive() Read Failed -1

E:[ 0] dispatcherEventSend: 738 Write failed -1

I tried running hello_ncs.py to verify if the stick was being detected and that seemed fine even though I still get the Read failed error but it does identify the device.

Comments

  • 7 Comments sorted by Votes Date Added
  • @dar5han Thank you for reporting this. This is a known issue with using the NCS with VMs, although it does not currently hinder any functionality of the device.

  • Hi Tome,
    I'm facing the same issue, but in my case after this message the program got frozen. I've reported the details in the thread "NCSDK 2.05 not working in Virtualbox 5.2 with Ubuntu 16.04.04"
    Since this is a known issue, do you have any workaround or recommendation?
    Thanks in advance!

  • I'm experiencing the same issue as dar5han. Any solution found for this yet?

    I am also running Ubuntu 16.04 VM on a windows 10 host.

  • Hi @Tome_at_Intel and others,
    I'm also getting the same behaviour as dar5shan. I can't run anything other than hello_ncs.py successfully (though that does give a read error as well as saying it was successful). I thought it might be power, I have tried a powered usb hub (though it is a usb2 hub) instead of direct laptop port, but still fails.

    ubuntu 16.04.4 LTS
    ncsdk 2.05.00.02
    virtualbox 5.2.6
    windows 10 host

    has anyone managed to resolve this or has further information on what to do?

    this is what hello_ncs.py returns;

    realsense@realsense-VirtualBox:~/ncsdk-2.05.00.02/examples/apps/hello_ncs_py$ python3 hello_ncs.py
    D: [ 0] ncDeviceCreate:307 ncDeviceCreate index 0

    D: [ 0] ncDeviceCreate:307 ncDeviceCreate index 1

    D: [ 0] ncDeviceOpen:501 File path /usr/local/lib/mvnc/MvNCAPI-ma2450.mvcmd

    I: [ 0] ncDeviceOpen:507 ncDeviceOpen() XLinkBootRemote returned success 0

    I: [ 0] ncDeviceOpen:536 XLinkConnect done - link Id 0

    D: [ 0] ncDeviceOpen:550 done

    I: [ 0] ncDeviceOpen:552 Booted 3-ma2450 -> VSC

    I: [ 0] getDevAttributes:373 Device attributes

    I: [ 0] getDevAttributes:376 Device FW version: 2.4.2450.f0

    I: [ 0] getDevAttributes:378 mvTensorVersion 2.4

    I: [ 0] getDevAttributes:379 Maximum graphs: 10

    I: [ 0] getDevAttributes:380 Maximum fifos: 20

    I: [ 0] getDevAttributes:382 Maximum graph option class: 1

    I: [ 0] getDevAttributes:384 Maximum device option class: 1

    I: [ 0] getDevAttributes:385 Device memory capacity: 522073264

    Hello NCS! Device opened normally.
    I: [ 0] ncDeviceClose:742 closing device

    E: [ 0] dispatcherEventReceive:200 dispatcherEventReceive() Read failed -1

    Goodbye NCS! Device closed normally.
    NCS device working.

    trying to run anything else gives;

    realsense@realsense-VirtualBox:~/ncsdk-2.05.00.02/examples/caffe/AlexNet$ python3 run.py
    E: [ 0] dispatcherEventSend:738 Write failed -1

    E: [ 0] dispatcherEventReceive:200 dispatcherEventReceive() Read failed -1

    then it freezes

    thanks.

  • @cjcarnaghi1 @murrayc Right now there isn't a workaround for the VM device disconnect issue for NCSDK 2. We appreciate your patience while we work on this issue. Thanks.

Sign In or Register to comment.