frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Raspian-Stretch Movidius NCSDK installation failure

Hi
I tried to implement a clean installation on raspian stretch in Rpi3 with a 32MB microSDcard.
Applied the usual to setup the latest stretch distro:
sudo apt-get update
sudo apt-get dist-upgrade

Used the Movidius documentation ( and raspian stretch tips) to effect the installation
The following error was returned:

Installation failed: Command 'sudo -H pip3 install –trusted-host files.pythonhosted.org
Cython graphviz scikit-image ' return code=1. Error on line 308' ./install-utilities.sh. will exit
Makefile:47: recipe for target 'install' failed

Any help to correct this error much appreciated

Comments

  • 6 Comments sorted by Votes Date Added
  • That should of course be a 32GB microSDcard!

  • I just recently installed all of this on a Pi and now I wish I wrote it down.
    I mistakenly installed version 1 of the NCSDK and version 2 of the NCAppZoo
    that did not go well. They need to both be version 2.
    That all being said..
    I do not recall executing this line sudo apt-get dist-upgrade and everything worked out ok.
    I did execute a sudo apt-get update

  • Oh and to install the NCSDK version 2 I used
    git clone -b ncsdk2 https://github.com/movidius/ncsdk.git

  • Hi
    I took heed of your comment and looked up the 'update' and 'upgrade' mechanisms on stackoverflow.

    I think the following is a correct synopsis:

    'sudo apt-get update' has the effect of loading newer package lists whereas 'sudo apt-get dist-upgrade' installs the newer package components but does not update to a newer system release. This means 'sudo apt-get update' must always be run before 'sudo apt-get dist-upgrade' .

    I think in your case you may have installed against a raspian distro that was not updated to the newest available. In my case I used 2018-04-raspbian-stretch.img and applied the update and upgrade commands.
    Result:
    Your installation worked.
    My installation failed.

    I looked into the state of my failed installation and found pip3 was not available ( I think used by python3 needed for the NCSDK installation ) so I applied the following (following on from PINTO's March7 suggestion):
    1)
    wget https://bootstrap.pypa.io/get-pip.py
    sudo python3 get-pip.py
    sudo reboot
    sudo python2 get-pip.py
    sudo reboot

    2) Inspection of the Installation error text appeared to imply a problem with Cython. I found that Cython was not installed in the raw distro so I applied:
    sudo pip3 install Cython
    I think precompiled components are supposed to be loaded if Cython is not present. Perhaps this was the point of failure.

    I applied the clone,make,install command again this time it reported 'Installation is complete'

    The Rpi distro installed is reported from 'uname -a' as:
    Linux raspberrypi 4.14.34-v7+ #110 SMP Mon Apr 16:15 BST 2018 armv71 GNU/Linux

    I elected to make the examples with OpenCV installed. So far this has reached 60% on the installation, takes many 10s of minutes!

    In summary:
    I have tentatively cleared the initial problem by installing pip3 and Cython but I am not clear where the underlying problem lays. Problem in raspian distro or the NCSDK installation? I would appreciate any clarification.

  • @jslawton Glad you were able to solve your initial issue by manually installing the dependencies. The OpenCV installation can take a while to build (~4-5 hours or so to build).

  • It took about two days to samples running. I installed Spyder 3 as well because you have break points in python that works sometimes at least and can help you find an issue quicker. Its still not 100% but at least I have some running examples.

Sign In or Register to comment.