frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Exception: mvncStatus.TIMEOUT

When we run the test with the USB stick, and we got the TIMEOUT message randomly:

Traceback (most recent call last):
File "./run_4line.py", line 113, in
output, userobj = graph.GetResult()
File "/usr/local/lib/python3.5/dist-packages/mvnc/mvncapy.py", line 264, in GetResult
raise Exception(Status(status))
Exception: mvncStatus.TIMEOUT

Any help?

Thanks

Comments

  • 14 Comments sorted by Votes Date Added
  • @dpan817 Thanks for reporting this issue. Are these apps in the ncappzoo or your own? I would also like to know which models you are using. Thanks.

  • @Tome_at_Intel I also met this issue when I run the Live-image-classifier, an app in the ncappzoo.

  • @q935110409 This doesn’t sound like a normal instance. You experience the timeout error randomly?

  • @Tome_at_Intel Yes, this issue appears randomly when I run the image-classifier.py and I think this is the reason why it also appears when I run the Live-image-classifier.py. Hope for your help, thanks.

  • @q935110409 It sounds like there could be an issue with your stick. I recommend requesting a replacement from the online retailer you purchased from if within 30 days of purchase. If more than 30 days have passed since your purchase, I recommend opening a warranty issue with Intel Support.

  • For my case, it is not random. it will timeout after about 8 minutes every time. The model is from our customer, not from ncappzoo. Both our customer and us can duplicate it consistently on different sticks, even after I added the external power supply for the USB hub.

    Actually, we are running stress test. After add about 5 seconds sleep after each loop, there is no timeout anymore. So it sounds like a hardware issue.

  • @dpan817 Depending on the network, it sounds like it could be thermal throttling issue.

  • @Tome_at_Intel is this a power consumption issue? I'm running real-time object detection application on NCS and when the raspberry was powered using laptop this happens very frequently. If it was powered using a external power adapter this happened after 2 hours. Have you any explanation over it?
    Some other methodology is also available here https://ncsforum.movidius.com/discussion/499/mvncstatus-timeout-raised-after-processing-few-frames-from-video-on-raspberry-pi

  • @chinthysl It could be related to power consumption also. Have you tried using a powered USB hub? The laptop USB port may not provide enough power for the RPi and the NCS device so that's likely why you're experiencing the issue more often. Depending on how many USB devices you have hooked up to the Pi, (keyboard, mouse, USB camera, NCS device, etc.) you may require a powered USB hub.

  • @Tom_at_Intel, My application needs to run a real-time obj detection for days, may be weeks. So I'm doing some perf test to measure the reliability of the module. I used a powered USB hub this time. Even though, I get the same error. But I could achieve a maximum of 17 hours this time. I have two sticks and both have the same issue. Is this the current behavior of the stick? If I close the device after a predefined time interval, will it work? Does it need cooling?

  • @chinthysl The sticks do have a thermal throttling feature when used with the NCSDK. Which version of the NCSDK are you using? If possible please check out NCSDK 2.05.00.02 and see if you are still getting the timeout issues. What kind of environment are you using the sticks in? Depending on the air restrictions, you may experience higher temps.

  • @Tome_at_Intel, After migrating to the NCSDK 2.0 problems are gone. I ran my tests using an external power supply for a week and no disconnection happened. And ran NCS with raspberry's power only. It is working fine. I think the new API fixed this issue.

  • @chinthysl Good to hear that. Let me know if there are any other issues. Have a good one.

Sign In or Register to comment.