frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

NCSDK Installation Improvements: We Want Your Feedback!

Hi everyone,

At Intel we are always striving to make improvements and raise our standards. Today we are asking for your feedback as customers and developers to help improve the Neural Compute SDK installation. Please feel free to reply to this announcement post and include any comments and improvements that you feel could improve the NCSDK installation. Thank you very much!

«1

Comments

  • 40 Comments sorted by Votes Date Added
  • Hi,
    I typically install everything in docker on my Ubuntu. So an "official" docker image would make the life (the installation) easier.
    Specially where we want to run multiple device at the same time, each in different container.
    ( just to follow the microservice concept, and may use the docker-compose scale funcionality)
    Thanx
    S&|

  • The documentation provides little information to fall back on if make install fails. In my case, the failure occurred at line 498; perhaps it is just a Python version or configuration issue, but I have no information about exactly what has gone wrong and the make error messages are not helpful.

    Actually, I am primarily interested in using Tensorflow. Is it practical to do a manual install to provide just the components I need? If I cannot build the SDK, am I just left with a pretty blue paperweight?

  • @sseres ,

    Here is docker build file. FYI.

    PS: this is not official file release by Intel.

    https://github.com/chesterkuo/DeepLearning_Docker/tree/master/Movidius-SDK

  • Another comment I wanted to suggest the dev team is to restructure the code such caffe / TF python bindings are imported only when they're absolutely needed. Being a only-TF user, I had set INSTALL_CAFFE=no because I had no need for it. But as soon as I try import mvnc, it starts complaining about pycaffe not being installed. This is slightly orthogonal to the topic in hand but I thought it's something that should be mentioned especially now that the team is doing a lot of rearchitecturing the code.

  • Hi, I'm trying to install NCSDK recently. But the installation makes me feel awful.
    I try this on ubuntu16.04, python2.7

    The " make install" works well now.
    But When I want to "make examples"
    I met this problem.

    making compile
    mvNCCompile -w bvlc_googlenet.caffemodel -s 12 deploy.prototxt
    mvNCCompile v02.00, Copyright @ Movidius Ltd 2016

    Error importing caffe
    make[4]: Leaving directory '/home/mc/workspace/ncsdk/examples/caffe/GoogLeNet'
    cp: cannot stat '../../caffe/GoogLeNet/graph': No such file or directory
    Makefile:9: recipe for target 'googlenet' failed
    make[3]: *** [googlenet] Error 1
    make[3]: Leaving directory '/home/mc/workspace/ncsdk/examples/apps/multistick_cpp'
    Makefile:12: recipe for target 'multistick_cpp/.' failed
    make[2]: *** [multistick_cpp/.] Error 2
    make[2]: Leaving directory '/home/mc/workspace/ncsdk/examples/apps'
    Makefile:12: recipe for target 'apps/.' failed
    make[1]: *** [apps/.] Error 2
    make[1]: Leaving directory '/home/mc/workspace/ncsdk/examples'
    Makefile:57: recipe for target 'examples' failed
    make: *** [examples] Error 2

    Does anybody know how to fix this?
    Many thanks.

  • I try to install the SDK and make the examples in last week.
    I think most of the process is OK, except download the 3rd packages and data files.

    In Shanghai, the site tensorflow.org can't be accept.
    berkeleyvision.org is very slow (0-20k/s).

    In sometime, the download is fault due to connection error or timeout.
    There is no break and obvious error in the output.
    When I run the 'make', there are strange errors.

    My suggestion is to detect the fault of download and return error to user.

  • Please, please support open standards so please add ONNX network format. Don't want to be stuck in the awful Caffe. ONNX is supported by CNTK, Chainer, Caffe2, MXNet and more. It is vastly establishing itself as the network format.

  • edited May 18 Vote Up1Vote Down

    Don't break releases! That is super important. Yesterday my engineers had to spend a couple of hours fixing bugs because we had checked out a specific release for the ncsdk (as per best practice). It was the most recent non-beta release when we wrote the code. It does not work anymore because you removed some file from AWS. That is absolutely not ok. Either you are building a product or a toy (your sales reps clearly told me NCS is meant to be a proper product with longer term support and all that stuff).
    On top of that the only release that works is the 2.x release (which does not contain the 2.x code, only 2.x readmes, I think). If you release your SDK via Github, use Github the way it is meant to be used.

    Sorry for voicing my frustration but my company is in the process on building a product that will use your hardware. We will be deploying 1000s of the NCS at retail stores all over Europe and I need reliable partners for my hardware stack.
    (I'll post this as a new topic as well)

  • I have so far found installation and setup of the Up Board very frustrating and not well documented. I have run into countless minor issues that I've managed to overcome or get around but I'd like to point out one in particular just in case anybody else sees this problem. I am surprised I haven't seen anyone else complain about issues with Pygraphviz but if you're getting errors running any of the mvNCxxxx commands that eventually drill down to the message:

    ImportError: /usr/local/lib/python3.5/dist-packages/pygraphviz/_graphviz.cpython-35m-x86_64-linux-gnu.so: undefined symbol: Agundirected

    then check out this GitHub issue comment for advice on how to resolve it:

    https://github.com/pygraphviz/pygraphviz/issues/115#issuecomment-344800405

  • Please check my post and follow-up comment here:

    https://ncsforum.movidius.com/discussion/876/mvnccompile-fails-illegal-instruction

    This seems like a pretty big installation issue. I can only assume that the reason it doesn't come up more often is that few people are trying out the Up Board and Neural Compute SDK together.

  • When can the software adapt to ubuntu18?

  • We also need **Ubuntu 18 **support or better general Linux support! I don't understand why it's bound to a special distro!

  • edited March 16 Vote Up0Vote Down

    @Tome_at_Intel

    Firstly, all of the installation issues posted on this Forum are as follows.
    It is not a problem of the NCSDK itself.

    1.Caffe (Especially environment specific problems of Makefile.config)
    2.OpenCV
    3.CUDA Version
    4.GCC Version
    5.Anaconda Version
    6.OS Version
    7.Problems referring to ppa by country
    8.with / without GPU

    Instead of automatically installing everything in the installation script, you can install these tasks as easily as possible by installing them individually.

    1.Caffe
    2.OpenCV

    In particular, since these two files have wheel files or many installation binaries (deb) on the web, we recommend that you install them yourself according to your environment.

    Ubuntu 16.04 or Ubuntu 17.04 + Caffe + CUDA example:
    http://caffe.berkeleyvision.org/install_apt.html

    Rapberry Pi (with Rapbian Stretch) + OpenCV3.4.1 example:
    sudo apt autoremove libopencv3
    wget https://github.com/mt08xx/files/raw/master/opencv-rpi/libopencv3_3.4.1-20180304.1_armhf.deb
    sudo apt install -y ./libopencv3_3.4.1-20180304.1_armhf.deb
    sudo ldconfig

  • Debian line + Caffe installation.
    By "apt install" command.
    Precautions concerning version of gcc are organized.
    http://caffe.berkeleyvision.org/install_apt_debian.html

  • Hello,
    I have a problem with my neural compute stick. I want to exposed these drive to others students so they can buy these but unfortunately my demonstration doesn’t work.
    Can you help me please ?
    I have a Mac (Apple) and I work with ubuntu. I would like to present a ncappzoo app (stream_infer) but when I write : make run in the terminal. I see : “make : *** [run] Erreur 1

    What can I do ?
    I really need these program for tomorrow.
    Thank you for your help !

  • @DavidD I would love to help you, but I think you should create a new forum thread in the discussions section so that we can keep the forums organized. Thanks.

  • Hi
    I am sure a more detailed walk thru of specific installations would be most helpful.

    For instance:
    1) Raspberrypi3 + Ubuntu 16.04
    2) Raspberry Pi3 +Raspian Stretch
    3) ASUS I3 + VirtualBox +Ubuntu16.04
    Authorative detail on where to locate the distros and an account of some of the trickier procedures ( eg Virtual Box USB filters) would be greatly appreciated.
    Any specific limitations eg a) Raspberry Pi3 needs swapfiles for the full NC SDK b) Is installation on a 32bit Intel reasonable. Is the Rasperrypi3 running in 32 bit mode with Debian/Ubuntu installation?

  • Support running NCS on Android platform.
    All of us has a cellphone and we'd like to do some experiment on it.

    Thanks

  • An addendum to my post of earlier today: I had tried to install on a machine with Anaconda/Python3.6 and a working installation of Tensorflow. I backed off and created a fresh VMWare virtual machine using Ubuntu 16.04 without any modifications except for the addition of a sexy girl wallpaper. The ncsdk installation script executed successfully and the Movidius examples compiled and ran without error.

  • Hi,

    Installation worked well on ubuntu 16.04.
    Tried on 18.04 and seems to work fine too.
    We made an install on raspberry without any trouble related to ncsdk but to Tensorflow.

    The documentation is not always easy to find but the forum is very active to help on this :)
    Thank's for the availability !

  • @malonzo Thank you for the feedback!

  • @malonzo did you have to edit the install.sh script (for the ncsdk2 branch)? I had to change that because 18.04 is not officially supported by movidius

  • @gokul_uf Yes, I changed the 1604 to 1804 in install.sh it seems to work pretty well (on the install side) but there are some incongruencies in between tutorials and some functions usage and I finally end-up with some issues see here

  • I am trying to get the stick working on a PI 3+. Been working on it since yesterday and not close to
    getting any of the ncappzoo samples running on the PI. In the forum you talk about using the latest version 2.0
    ncsdk but if you go to Documentation and Downloads it points you to the github version 1.x . I downloaded and installed.
    In reading the readme at github it said I should download the version 2 ncappzoo samples. So something here is not in sync.
    I did download those samples and they dont work correctly so I found and downloaded the older ncappzoo samples.
    I can run hello_ncs_py and it can open the stick. Its the only sample I was able to get running so far.
    I was most interested in Tiny Yolo and I think there was a post that said Tiny Yolo was available in the ncappzoo. Is that in version 2? I ran across a how to update from version 1.x to 2.x someplace but can not seem to find it now.
    Then I read not all samples work with version 2.x SO I am truly confused. My main goal is to work with Tiny Yolo on the Pi.
    Can you give me a hand to get that to happen? PS I am not a Linux expert.

  • @chicagobob123, I believe I ran into a similar issue, and my understanding right now is that you will need the v1 sdk for Rpi deployment. Specifically I had run into this: https://ncsforum.movidius.com/discussion/830/cannot-find-lmvnc-highclass and there appears to be no workaround as yet.

    I'm also interested in yolo on the Pi so keep me posted if you get that working. Initially, I set up a development VM with x64 Ubuntu but it seems this may not be a good idea either since the Pi is 32 bit. Trying to get a feel for the workflow still -- it wasn't obvious to me that while you can technically install on the Pi, you're probably best off developing in a VM or dedicated machine and just installing the API on the Pi (plus any python libraries needed to run .pys)

    If you are running into memory-related errors with the Pi examples, tome suggested something useful which I haven't tried yet -- increase the swap size on your Pi. By default it's quite low. Granted, it seems like a better idea to just avoid heavy swap usage on the SD card if you can (hence the suggestion to develop in VM, deploy on Pi)

  • Ubuntu 16.04 has both py2 and py3. when installing NCSDK, the pip2 and pip3 in install.sh is confusing. Can add a argument for user to choose which pip will use?

  • @thomascatlee , thank you for your feedback. We will look into this, and see if we can make a change.

  • edited June 27 Vote Up0Vote Down

    I've tried to install the ncsdk on both Ubuntu 16.04 and Raspbian stretch, and it fails on both.
    Can somebody please help me ?

  • @Spyder Please open a new forum topic for your issue and please be sure to include the error message that you are seeing during the install.

  • edited July 12 Vote Up0Vote Down

    @yyx

    I do not know if I can help you.
    See below.

      :
    Error importing caffe
      :
    

    If this still seems to be an error, Caffe will not be installed properly.

    $ export PYTHONPATH=/opt/movidius/caffe/python:$PYTHONPATH
    $ source ~/.bashrc
    $ make examples
    
Sign In or Register to comment.