frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

mvNCCompile error for Inception-Resnet-V2 with tensorflow

Comments

  • 5 Comments sorted by Votes Date Added
  • edited December 2017 Vote Up0Vote Down

    I saw the** ncsdk 1.10.1 can support inception-resnet-v2 model with tensorflow.**
    I trained this model for facenet, got some files for check point in tensorflow, and i want to covert it for NCS.
    But I get some error, anyone help me to check what worng is?
    Or is there a example for inception-resnet v2 with NCS?

    Thanks.

    My command:
    $mvNCCompile model-20171204-174419.meta -s 12 -in=input -on=Predictions -is 160 160 -o Inception-resnet-v2.graph

  • edited December 2017 Vote Up0Vote Down

    The error is as below:
    mvNCCompile v02.00, Copyright @ Movidius Ltd 2016

    /usr/local/lib/python3.5/dist-packages/tensorflow/python/util/tf_inspect.py:45: DeprecationWarning: inspect.getargspec() is deprecated, use inspect.signature() instead
    if d.decorator_argspec is not None), _inspect.getargspec(target))
    WARNING:tensorflow:The saved meta_graph is possibly from an older release:

    ...

    Caused by op 'save/RestoreV2_740', defined at:
    File "/usr/local/bin/mvNCCompile", line 118, in
    create_graph(args.network, args.inputnode, args.outputnode, args.outfile, args.nshaves, args.inputsize, args.weights)
    File "/usr/local/bin/mvNCCompile", line 104, in create_graph
    net = parse_tensor(args, myriad_config)
    File "/usr/local/bin/ncsdk/Controllers/TensorFlowParser.py", line 190, in parse_tensor
    saver = tf.train.import_meta_graph(path)
    File "/usr/local/lib/python3.5/dist-packages/tensorflow/python/training/saver.py", line 1698, in import_meta_graph
    **kwargs)
    File "/usr/local/lib/python3.5/dist-packages/tensorflow/python/framework/meta_graph.py", line 656, in import_scoped_meta_graph
    producer_op_list=producer_op_list)
    File "/usr/local/lib/python3.5/dist-packages/tensorflow/python/framework/importer.py", line 313, in import_graph_def
    op_def=op_def)
    File "/usr/local/lib/python3.5/dist-packages/tensorflow/python/framework/ops.py", line 2630, in create_op
    original_op=self._default_original_op, op_def=op_def)
    File "/usr/local/lib/python3.5/dist-packages/tensorflow/python/framework/ops.py", line 1204, in __init__
    self._traceback = self._graph._extract_stack() # pylint: disable=protected-access

    NotFoundError (see above for traceback): Unsuccessful TensorSliceReader constructor: Failed to find any matching files for model-20171204-174419
    [[Node: save/RestoreV2_740 = RestoreV2[dtypes=[DT_FLOAT], _device="/job:localhost/replica:0/task:0/cpu:0"](_arg_save/Const_0_0, save/RestoreV2_740/tensor_names, save/RestoreV2_740/shape_and_slices)]]

  • Any luck getting this working?

  • I faced the same error. It was so trivial that it was embarrasing.
    Just change the name of your meta file such that it ends with 'ckpt.meta', same extension as the checkpoint file

Sign In or Register to comment.