frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Alert: Beginning Tuesday, June 25th, we will be freezing this site and migrating the content and forums to our new home at https://forums.intel.com/s/topic/0TO0P000000PqZDWA0/intel-neural-compute-sticks. Check it out now!

RuntimeError in make examples

Hi,
I had a RuntimeError in make examples.

RuntimeError: module compiled against API version 0xb but this version of numpy is 0xa

Please give me any advice to solve the problem.

My environment:

Raspberry PI3, Raspbian stretch with desktop
Movidius NC SDK version: 1.10.01.00

$ uname -a
Linux raspberrypi 4.9.59-v7+ #1047 SMP Sun Oct 29 12:19:23 GMT 2017 armv7l GNU/Linux

My operation:

I followed the Movidius quick start guide below.

mkdir -p ~/workspace
cd ~/workspace
git clone https://github.com/movidius/ncsdk.git
cd ~/workspace/ncsdk
make install

After make install, there are no error.
I opened a new terminal window and checked environment variable, PYTHONPATH=:/opt/movidius/caffe/python.
then,
cd ~/workspace/ncsdk
make examples
Continue installing OpenCV (y/n) ? n

Message:

I got the following message;
...
...
making compile
mvNCCompile -w bvlc_googlenet.caffemodel -s 12 deploy.prototxt
mvNCCompile v02.00, Copyright @ Movidius Ltd 2016

Traceback (most recent call last):
File "/usr/local/bin/mvNCCompile", line 118, in
create_graph(args.network, args.inputnode, args.outputnode, args.outfile, args.nshaves, args.inputsize, args.weights)
File "/usr/local/bin/mvNCCompile", line 100, in create_graph
from Controllers.CaffeParser import parse_caffe
File "/usr/local/bin/ncsdk/Controllers/CaffeParser.py", line 29, in
import caffe
File "/opt/movidius/caffe/python/caffe/init.py", line 1, in
from .pycaffe import Net, SGDSolver, NesterovSolver, AdaGradSolver, RMSPropSolver, AdaDeltaSolver, AdamSolver, NCCL, Timer
File "/opt/movidius/caffe/python/caffe/pycaffe.py", line 15, in
import caffe.io
File "/opt/movidius/caffe/python/caffe/io.py", line 2, in
import skimage.io
File "/usr/local/lib/python3.5/dist-packages/skimage/io/init.py", line 7, in
from .manage_plugins import *
File "/usr/local/lib/python3.5/dist-packages/skimage/io/manage_plugins.py", line 28, in
from .collection import imread_collection_wrapper
File "/usr/local/lib/python3.5/dist-packages/skimage/io/collection.py", line 14, in
from ..external.tifffile import TiffFile
File "/usr/local/lib/python3.5/dist-packages/skimage/external/tifffile/init.py", line 1, in
from .tifffile import imsave, imread, imshow, TiffFile, TiffWriter, TiffSequence
File "/usr/local/lib/python3.5/dist-packages/skimage/external/tifffile/tifffile.py", line 293, in
from . import _tifffile
RuntimeError: module compiled against API version 0xb but this version of numpy is 0xa
Makefile:80: target 'compile' recipe failed
make[4]: *** [compile] Error 1
...
...

Thanks,

Comments

Sign In or Register to comment.