Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Alert: This site is migrating to our new home at Please visit us there!

Collective Knowledge packages and workflows for NCSDK and tinyYOLO

Hello all,
Today we added new Collective Knowledge packages and sample workflows for Movidius Neural Compute Stick and tinyYOLO (image classification and object detection). Please check out the ReadMe with more details here: .This is a part of our community effort to unify and automate installation and execution of various DNN applications across different platforms. Hope it will be of any help!
Take care,


  • 7 Comments sorted by Votes Date Added
  • @gfursin Sure i will test it and let you know tomorrow.

  • edited November 2017 Vote Up1Vote Down

    I don't have PiCam so couldn't test it - I used USB2 Logitech C525 webcam to test live ojbect detection example on my RPi3. If PiCam uses OpenCV for interfacing, I guess it should also work ... If you will decide to test it, may I ask you to tell me if it works, please - I will then update my notes! Thanks!

  • works on my Dell laptop with Ubuntu 17.04. very convenient. thanks!!

  • Good job, Thats useful.
    does this support Raspberry Pi PiCam?

  • What if i have already install ncsdk? should i skipp installing it through ck?

  • Never mind my last comment.
    Anyways i tried to run it using PiCam i stuck here

    [INFO/ForkPoolWorker-1] process shutting down                                       
    [DEBUG/ForkPoolWorker-1] running all "atexit" finalizers with priority >= 0         
    [DEBUG/ForkPoolWorker-1] running the remaining "atexit" finalizers                  
    Process ForkPoolWorker-1:                                                           
    Traceback (most recent call last):                                                  
      File "/usr/lib/python3.5/multiprocessing/", line 249, in _bootstrap                                                                          
      File "/usr/lib/python3.5/multiprocessing/", line 93, in run             
        self._target(*self._args, **self._kwargs)                                       
      File "/usr/lib/python3.5/multiprocessing/", line 103, in worker            
      File "/home/pi/CK-TOOLS/demo-mvnc-yolo-linux-32/yoloNCS/py_examples/object_detec$ 
        graph.LoadTensor(resize(frame/255.0,dim,1)[:,:,(2,1,0)].astype(np.float16), 'u$ 
    TypeError: unsupported operand type(s) for /: 'NoneType' and 'float'                
    [INFO/ForkPoolWorker-1] process exiting with exitcode 1                             
    [DEBUG/MainProcess] cleaning up worker 0                                            
    [Level 5/MainProcess] finalizer calling <built-in function close> with args (18,) $ 
    [DEBUG/MainProcess] added worker                                                    
    [DEBUG/ForkPoolWorker-3] Queue._after_fork()                                        
    [DEBUG/ForkPoolWorker-3] Queue._after_fork()                                        
    [INFO/ForkPoolWorker-3] child process calling          
  • Hi @GoldenWings,

    I saw this error once when OpenCV was not properly installed, i.e. when I installed it myself instead of using the one from ncsdk.

    The thing is that there is no check that something is really returned from your camera via OpenCV in the python code taken from . So if frame = is None, the code will fail as in your case.

    During reinstalling ncsdk on RPi3 (you can do it either via CK or manually - CK can automatically detect if you already have it installed) I was asked to install OpenCV (took around 2 hours to complete) and it worked fine then.

    Also, I guess you use latest Raspbian Stretch (, right?

    Alternatively, you can try to run internal Movidius examples (just invoke "ck run program:demo-mvnc-yolo --cmd_key=run-internal-movidius-examples") - if OpenCV is not properly installed, I think the script in ncsdk will ask you to (re)install OpenCV. You can then try to test your PiCam with some other sample python3 program to see if it can actually read the stream ...

    Hope it will help you!

Sign In or Register to comment.