frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Error in installing SDK in Raspberry Pi. Couldn't find a supported tensorflow version,

My environment is Raspberry Pi 2 model B (ARMv7 processor).
NCSDK 1.10.00.

I tried make install on installing NCS SDK.
I encountered the same situation as the error described below.
"Couldn't find a supported tensorflow version, installing tensorflow v1.3.0"
https://ncsforum.movidius.com/discussion/308/installation-error-on-sdk-1-09-00-fails-to-find-install-tensorflow

I follow the above discussion, I tried make install as a non-root user, but sudo will be executed automatically during make install.

So I separately downloaded Tensorflow and installed version 1.3.0 whl for Raspberry PI2 (ARMv7) from the following.
https://github.com/DeftWork/rpi-tensorflow/
wget https://github.com/DeftWork/rpi-tensorflow/raw/master/tensorflow-1.3.0-cp27-none-linux_armv7l.whl
sudo pip install tensorflow-1.3.0-cp27-none-linux_armv7l.whl

And I edited SDK file, ncsdk/ncsdk.conf and changed it as follows.
INSTALL_TENSORFLOW = no
After changing, run make install again and setup is complete.

Is this the right way? Does something go wrong?
Do I need to use Tensorflow version 1.3.0?

Comments

Sign In or Register to comment.