Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Alert: Beginning Tuesday, June 25th, we will be freezing this site and migrating the content and forums to our new home at Check it out now!

Steps for installtion for Raspberry Pi 3 new sdk



  • Hello,

    I ran the installation on a RpI 3+, camera and 7 inch display installed, NCS occupies a USB slot directly. I am able to run the test models for GoogLeNet, SqueezeNet and AlexNet (getting also the "unsufficient memory" error as stated above).
    But anything "tensorflow" does not work ..


    pi@raspberrypi:~/workspace/ncappzoo/tensorflow/inception $ make run
    TF_SRC_PATH not set, making tf_src
    (cd ../tf_src; make all; cd /home/pi/workspace/ncappzoo/tensorflow/inception)
    make[1]: Entering directory '/home/pi/workspace/ncappzoo/tensorflow/tf_src'
    TF_SRC_PATH not set, will use project directory
    TF_SRC_PATH is now: /home/pi/workspace/ncappzoo/tensorflow/tf_src/tensorflow
    skipping clone, directory already exists: /home/pi/workspace/ncappzoo/tensorflow/tf_src/tensorflow
    make[1]: Leaving directory '/home/pi/workspace/ncappzoo/tensorflow/tf_src'
    TF_SRC_PATH is /home/pi/workspace/ncappzoo/tensorflow/inception/../tf_src/tensorflow
    Downloading checkpoint files...
    (mkdir -p model/v3)
    (cd model/v3; wget -nc;)
    File ‘inception_v3_2016_08_28.tar.gz’ already there; not retrieving.
    (cd model/v3; tar -xvf inception_v3_2016_08_28.tar.gz;)
    TF_MODELS_PATH not set, making tf_models
    (cd ../tf_models; make all; cd /home/pi/workspace/ncappzoo/tensorflow/inception)
    make[1]: Entering directory '/home/pi/workspace/ncappzoo/tensorflow/tf_models'
    TF_MODELS_PATH not set, will use project directory
    TF_MODELS_PATH is now: /home/pi/workspace/ncappzoo/tensorflow/tf_models/models
    Skipping clone, directory already exists: /home/pi/workspace/ncappzoo/tensorflow/tf_models/models
    make[1]: Leaving directory '/home/pi/workspace/ncappzoo/tensorflow/tf_models'
    TF_MODELS_PATH is /home/pi/workspace/ncappzoo/tensorflow/inception/../tf_models/models
    Exporting GraphDef file...
    (cd model/v3; python3 /home/pi/workspace/ncappzoo/tensorflow/inception/../tf_models/models/research/slim/ \
        --alsologtostderr \
        --model_name=inception_v3 \
        --batch_size=1 \
        --dataset_name=imagenet \
        --image_size=299 \
    Traceback (most recent call last):
      File "/home/pi/workspace/ncappzoo/tensorflow/inception/../tf_models/models/research/slim/", line 59, in <module>
        import tensorflow as tf
    ImportError: No module named 'tensorflow'

    The same for any other TF related test run.

    What could i do? I followed the instruction from of cause.

    I am really eager to start with some of my models running on one or more NCS soon.



  • @jfey We currently don't have support for TensorFlow on the Raspberry Pi yet. Please refer to the release notes for the Neural Compute SDK version 1.12 @ and scroll down to the Errata section.

  • @Tome_at_Intel : Well, that explains why i can not proceed. Thanks for your response. I will then work with Caffe on the RPi (good enough for a lot of use cases anyways, but i just have this habit to look for TF) and migrate to an X86 based Ubuntu for TF.

  • @jfey You're welcomed. If there is any progress made on this, I will contact you or float this thread to the top. Have a good one.

  • @Tome_at_Intel is tensorflow for raspberry pi supported in the latest SDK ?

  • @karthik I was able to build graph files for the TensorFlow examples for NCSDK 2. Give it a shot and let me know how it goes,

  • edited May 2018 Vote Up0Vote Down

    @Tome_at_Intel I haven't got the device yet, the device is on the way. I'll check then and update

    I tried installing only the api as mentioned in this blog post : but it fails at the make command and gives the following error :

    cc -shared obj-armv7l/mvnc_api.o obj-armv7l/fp16.o obj-armv7l//home/pi/workspace/ncsdk/api/src/common/components/XLink/pc/usb_boot.o obj-armv7l//home/pi/workspace/ncsdk/api/src/common/components/XLink/shared/XLink.o obj-armv7l//home/pi/workspace/ncsdk/api/src/common/components/XLink/shared/XLinkDispatcher.o obj-armv7l//home/pi/workspace/ncsdk/api/src/common/components/XLinkConsole/pc/XLinkConsole.o obj-armv7l//home/pi/workspace/ncsdk/api/src/common/components/XLink/pc/UsbLinkPlatform.o -o obj-armv7l/ -lpthread -lusb-1.0 -ldl -lmvnc_highclass -L/usr/local/lib/
    /usr/bin/ld: cannot find -lmvnc_highclass
    collect2: error: ld returned 1 exit status
    Makefile:50: recipe for target 'obj-armv7l/' failed
    make: *** [obj-armv7l/] Error 1

    I used the NCSDK2 for the api... what went wrong ?

  • Hi @karthik the error you got with ncsdk 2.04 when building the api as the blog describes is a known issue with that release and is planned to be fixed in the next release. In general NCSDK2 (including the 2.04 release) installs and runs on RPi very close to the way it work on Ubuntu. That is clone the repo and run make install should work.

    There is a note regarding Raspberry Pi on the installation page in the 2.04 documentation that you will want to take a look at. I'll copy here as its easy to miss:

    Raspberry Pi Installation Notes
    We recommend a 16GB SD card for a full NCSDK installation.

    You will likely need to increase the swapfile size on the Raspberry Pi in order to successfully complete NCSDK and/or OpenCV installation. To increase the swapfile size, edit the value of CONF_SWAPSIZE in /etc/dphys-swapfile:

    sudo nano /etc/dphys-swapfile

    The default value is 100 (MB). We recommend that you change this to 1024 (MB) or greater.

    Then restart the swapfile service:

    sudo /etc/init.d/dphys-swapfile restart

    After you have installed the NCSDK (and optionally OpenCV), you should change the swapfile size back to 100 MB

  • Thanks @neal_at_intel. Was able to install the SDKv2 on raspberry pi

Sign In or Register to comment.