frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

NCSDK 1.09.00.04 install issue

I saw a similar failure on the board with response which doesn't work for me... I don't know how to reopen that case..
I have an ubuntu 16.04 IA machine, with opencv 3.3 installed. After typing make install as normal user, I'm asked to type in sudo password.. Install continues until it hits the following error:Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 95 not upgraded.
Installing python dependencies...
./install-ncsdk.sh: line 282: -H: command not found
./install-ncsdk.sh: line 283: -H: command not found
Checking whether tensorflow is installed...
looking for tensorflow CPU version...
./install-ncsdk.sh: line 248: -H: command not found
looking for tensorflow GPU version...
./install-ncsdk.sh: line 248: -H: command not found
Couldn't find a supported tensorflow version, installing tensorflow v1.3.0
./install-ncsdk.sh: line 303: -H: command not found

The solution was to go edit /opt/movidius/NCSDK/install..sh script. when I go to that directory I can see uninstall-ncsdk.sh but not install-ncsdk.sh or anything close to it.. So, I've tried running as non root, root, sudo make install.. and everything leads to the error above.. I can't see the install script in /opt/movidius/NCSDK/

Appreciate your help..

Comments

  • 3 Comments sorted by Votes Date Added
  • As it turns out, my machine is very fast and I couldn't stop the make install fast enough. I put an exit right before ./install-ncsdk.sh to catch it right before it goes on to execute the main install in /opt/movidius/NCSDK.

    untar the new install and run the install script

    sudo tar zxvf ./ncsdk.tar.gz
    sudo rm -rf NCSDK
    sudo mv $ncsdk_pkg* NCSDK
    cd /opt/movidius/NCSDK
    sudo cp /tmp/ncsdk.conf .
    echo "exiting"
    exit
    ./install-ncsdk.sh

    Found the install script and edited it as per "installation error on SDK 1.09.00 fails to find/install Tensorflow" .

    sudo ./install-ncsdk.sh seems to have worked. It does say: "Adding user 'root' to 'users' group" which seems wrong..

    BTW I did add sudo to "cp /tmp/ncsdk.conf ." . I was getting cp permission denied prior to that...

    At this stage I only need to resolve the Adding user root users group.. Shouldn't that be my userid?

  • Not sure why the #untar... comment in the script turned bold..

  • @Anassib There is a problem with installing the SDK as root at the moment. This is a known issue that will be fixed in a future release. In addition, another user has posted his own patch that you may want to give a shot in this thread: https://ncsforum.movidius.com/discussion/comment/707/#Comment_707

Sign In or Register to comment.