frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

movidius stick on pine64

I wanted to use the neural computing stick on the PINE64 platform. CMIIW, from the web, I understood, if the stick works on raspberry(arm64, armv8) then it should work on PINE64

I have followed the instructions in the video links

and then for the raspberry pi

when I was installing the *.deb packages in pi_jessie folder I ran into errors about incompatible architectires armhf and arm64
dpkg: error processing archive mvnc_1.07_armhf.deb (--install):
package architecture (armhf) does not match system (arm64)

for uname -a on pine64, I got
$ uname -a
Linux pine64 3.10.105-bsp-1.2-ayufan-77 #1 SMP PREEMPT Sun Jul 9 12:09:30 UTC 2017 aarch64 aarch64 aarch64 GNU/Linux
I am running xenial Ubuntu

I am going to install Armbian Ubunutu on pine64, I am hoping this may be armhf architecture
how do I get/install the armhf architecture on Pine64?
any help is appreciated
Thanks

Comments

  • 6 Comments sorted by Votes Date Added
  • I have installed armbian on pine64, yet I ran into same problem with the Ubuntu Xenial/longsleep
    can anyone guide me how do I install the debian packages on Pine64?
    Does anyone have instructions to compile the packages(into .deb) from the sources?

    I am pasting the output here from the pine64


    pine64:~/ncapi/redist/pi_jessie$ sudo dpkg -i *.deb
    Selecting previously unselected package mvnc:armhf.
    (Reading database ... 135512 files and directories currently installed.)
    Preparing to unpack mvnc_1.07_armhf.deb ...
    Unpacking mvnc:armhf (0.0.36+0~20170713190651.36~1.gbpef8e6c) ...
    Selecting previously unselected package mvnc-dev:armhf.
    Preparing to unpack mvnc-dev_1.07_armhf.deb ...
    Unpacking mvnc-dev:armhf (0.0.36+0~20170713190651.36~1.gbpef8e6c) ...
    Selecting previously unselected package python3-mvnc.
    Preparing to unpack python3-mvnc_1.07_all.deb ...
    Unpacking python3-mvnc (0.0.36+0~20170713190651.36~1.gbpef8e6c) ...
    dpkg: dependency problems prevent configuration of mvnc:armhf:
    mvnc:armhf depends on libusb-1.0-0 (>= 2:1.0.19).

    dpkg: error processing package mvnc:armhf (--install):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of mvnc-dev:armhf:
    mvnc-dev:armhf depends on mvnc; however:
    Package mvnc:armhf is not configured yet.

    dpkg: error processing package mvnc-dev:armhf (--install):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-mvnc:
    python3-mvnc depends on mvnc.
    python3-mvnc depends on python3-numpy; however:
    Package python3-numpy is not installed.
    python3-mvnc depends on mvnc-dev; however:

    dpkg: error processing package python3-mvnc (--install):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    mvnc:armhf
    mvnc-dev:armhf
    python3-mvnc
    user@pine64:~/ncapi/redist/pi_jessie$ lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 16.04.2 LTS
    Release: 16.04
    Codename: xenial
    user@pine64:~/ncapi/redist/pi_jessie$
    user@pine64:~/ncapi/redist/pi_jessie$ uname -a
    Linux pine64 3.10.105-pine64 #1 SMP PREEMPT Wed Jun 7 12:04:01 CEST 2017 aarch64 aarch64 aarch64 GNU/Linux
    user@pine64:~/ncapi/redist/pi_jessie$


    Thank you

  • @dinu Sorry that you are having problems with using the NCS. The NCS and the Intel Movidius NCS SDK was designed for physical machine running x86 64-bit Ubuntu 16.04 and Raspian Jessie on the Rasperry Pi. There is currently no support for other architectures/operating systems, but we will keep an open mind regarding other platforms. We appreciate your feedback and please feel free to the forums as your voice. Thanks.

  • @Tome_at_Intel I thought aarch64 architecture is same as the Raspberry Pi 3 and theoretically if the debian packages installed on Pi 3, then the debian packages should be installed on other ARM64 platforms like Pine64, I do not know where the differences are.
    Appreciate your comment
    Thanks

  • RPI are 32-bit only devices not aarch64.

  • @victorv The last board from Raspberry is actually based on BCM2837 which is 64bit CPU.

  • @dinu Rather than installing debian packages maybe you can recompile the API yourself on the board. Just get the RPi3 version of the API and on the Pine64 you should try "make" and then "make install". Can you please try this and come back with what happened. Probably you will need "sudo" privileges I think.

Sign In or Register to comment.