frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Latest version 1.07.07 doesn't install on Ubuntu 16.04

Downloaded the latest version, which "includes" RPi support. I wonder does that expression "Includes" RPi support actually mean that this is the RPi version and users of Intel machines should not be attempting to use it? It did say that it was the "Latest" version so I took it.
It has trouble with the version of protoc installed on Ubuntu 16.04

Should I not be using 1.07.07, not be using Ubuntu 16.04 or not using the package manager's version of protoc?

Comments

  • 18 Comments sorted by Votes Date Added
  • Please note that even 1.07.07 is the "latest" version it includes SDK V1.07.06. Toolkit unmodified.
    Main changes are in API with added support for RaspberryPi* 3 Model B.

  • I'm actually now getting into this problem. To install the Toolkit the instructions state that you just enter the bin directory and execute "./setup.sh" that script does not actually install the requirements so prior to that step you should install the requirements:
    sudo pip install -r requirements.txt

    Actually prior to that step I've found that "scipy" is not installed so actually prior to installing the requirements listed in requirements.txt you should execute:
    sudo pip install scipy

    Now my problem is that when I get back to executing the setup.sh script it fails because my username can't be added to
    the group "users". I had to simply rerun the script with "sudo ./setup.sh" and that has worked for the Toolkit

    The API is another matter. Struggling to get past a lot of errors listed for libmvnc.so it might take a full shutdown after the install of the toolkit so I'll try that.

    OSError: ./libmvnc.so: cannot open shared object file: No such file or directory
    OSError: /usr/lib/libmvnc.so: undefined symbol: libusb_strerror

  • No this is not going to install on this machine. Can somebody who has this installed tell me what lib they are using for the libusb_strerror symbol

  • @jwhitmore Sorry to hear that the setup script isn't working for you. Barring some network problems on the Berkeley server side, the NCS SDK setup scripts should work with no problems on a physical machine running Ubuntu 16.04 natively. Can you please provide more information about the machine you are using? Are you running this on a physical Ubuntu 16.04 machine natively, Raspberry Pi or on a virtual machine? Thanks.

  • I have now tried to install the API on two Ubuntu 16.04 machines. Both are physical machines but I guess I could install a VM of 16.04 on a physical machine running 16.04.

    The problem on both machines is the same:

    OSError: /usr/lib/libmvnc.so: undefined symbol: libusb_strerror

    I don't know what version of libusb you're installing on your machines but it's not the same as the version being installed from the package manager on my machine. If you could tell me what version of libusb you have that would be some help. Having tried this on 2 versions of 16.04 which are up to date I wonder have Movidius tried to install on an Ubuntu 16.04 machine which is up to date? I guess if you can report your version of libusb we'll get some idea.

  • @jwhitmore Here is a snapshot from my current config for your reference.
    $ libusb-config --version
    0.1.12

  • I have libusb-config --version of 0.1.12 so I have exactly the same lib as required but also have a error message from libmvnc.so

    I can't understand why I'm using the tested distro and installing with the install script but getting different results. I'll have to try and debug what library calls are being made to which libraries. :-( I'll try install with a 16.04 VM and see if that makes a difference.

  • Interesting result from a 16.04 Gnome version. Different error installing the API. It's not in the developer.movidius.com/start/troubleshooting web page, but then none of my errors ever are. That would be too easy.

    [Error 9] Argument Error: Network weight cannon be found.
    mvNCCompile v02.00, Copyright @ Movidius Ltd 2016.

    I did kill the terminal after installing tools but might shutdown the VM and startup again to see if that clears that error.

    No restarting the VM didn't clear that problem. So having tried a few 16.04 physical machines and now a Virtual machine I'm starting to wonder about this product.

  • Hold on. On the VM the ncapi/setup.sh file is trying to download content from dl.dropboxusercontent.com and getting a lot of 404 errors so I assume that the content required for install just isn't available at present.

    Still I don't think I can resolve that issue

  • It appears that I have made an error in my assumption that there is a problem with my libusb as the error message is complaining about a missing symbol libusb_stderror. The problem is libmvnc.

    I should explain that inspite of the API install being unable to complete, because parts of the install SW which the installer is looking for on dropboxusercontent aren't there, I have been able to do some tests on the VM. Basically the problem I'm having on my physical machines can be reproduced with 2 lines of python:

    from ctypes import *
    f = CDLL("libmvnc.so")

    Thats it. These lines on my physical machines produce an error (libusb_stderror) where as on the VM the lines work without out error. I assumed that the problem was libusb and searching for that symbol produced no results. However I have now gotten a VM where those two lines of python complete without error. So I search through that VM's version of libusb for the missing symbol:

    nm -D /usr/lib/libusb-1.0.so.0 | grep stderror

    That's actually the command from my physical machine. The Ubuntu VM for some reason has it's libs under /lib anyway the result is the same in both cases. The VM's version of libusb doesn't contain that symbol so my machines and the VM are consistent but the results of CDLL are not. So where is libmvnc.so looking for that symbol?
    I don't have access to libmvnc source so I guess I should ask this question of somebody in Movidius (an Intel company) as this is a community forum. I'll have a look and see if I can't find somebody to resolve the growing number of issues.

    Out of interest is anybody else having problems with API install, given the dropbox content problems I'm having?

  • --2017-09-06 13:03:57-- https://dl.dropboxusercontent.com/u/38822310/gender_net.caffemodel
    Resolving dl.dropboxusercontent.com (dl.dropboxusercontent.com)... 162.125.64.6
    Connecting to dl.dropboxusercontent.com (dl.dropboxusercontent.com)|162.125.64.6|:443... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2017-09-06 13:03:57 ERROR 404: Not Found.

    --2017-09-06 13:03:57-- https://dl.dropboxusercontent.com/u/38822310/age_net.caffemodel
    Resolving dl.dropboxusercontent.com (dl.dropboxusercontent.com)... 162.125.64.6
    Connecting to dl.dropboxusercontent.com (dl.dropboxusercontent.com)|162.125.64.6|:443... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2017-09-06 13:03:58 ERROR 404: Not Found.

    --2017-09-06 13:03:58-- https://dl.dropboxusercontent.com/u/38822310/mean.binaryproto
    Resolving dl.dropboxusercontent.com (dl.dropboxusercontent.com)... 162.125.64.6
    Connecting to dl.dropboxusercontent.com (dl.dropboxusercontent.com)|162.125.64.6|:443... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2017-09-06 13:03:59 ERROR 404: Not Found.

  • Yes, I also get 404 errors, breaking the rest of the script. I started a thread on that here https://ncsforum.movidius.com/discussion/214/404-errors-in-ncapi-setup-sh/p1

  • @tveltrop @jwhitmore Thanks for bringing this to our attention. Regarding the 404 error with dropbox, we are working with the owner of the files to fix his broken links. I will make an announcement in this post https://ncsforum.movidius.com/discussion/214/404-errors-in-ncapi-setup-sh#latest when the links to the files are fixed.

  • @jwhitmore Can you confirm that you are running the SDK on a x86 64-bit machine? The SDK was built to run on x86 64-bit machines running Ubuntu 16.04 natively.

  • Yes the SDK is failing on two 64 bit x86 machines. I just wish that I knew what lib is missing that provides the symbol libusb_stderror. And it's not libusb as on a working VM that lib don't have any such symbol. Since your libmvnc.so has the problem I do wish you'd provide an error message to say lib*** is missing please install.

    I'm an embedded SW engineer so I have a lot of dev environments in, one of those is the Microchip IDE which is 32Bit. that means to install a few 32bit libs have to be installed. I thought that might be the problem but I did install that into the VM and libmvnc.so is still happy so it's not that IDE. I don't think the NXP IDE will be an issue. If I knew what lib is missing I could look at it to see what the issue is rather then guessing and trying to trace the issue.

  • I'm having a similar error when I try to build the examples that are packaged with the NCSDK:

    making compile
    mvNCCompile -w bvlc_googlenet.caffemodel -s 12 deploy.prototxt
    Traceback (most recent call last):
      File "/usr/local/lib/python3.5/dist-packages/mvnc/mvncapi.py", line 25, in <module>
        f = CDLL("./libmvnc.so")
      File "/usr/lib/python3.5/ctypes/__init__.py", line 347, in __init__
        self._handle = _dlopen(self._name, mode)
    OSError: ./libmvnc.so: cannot open shared object file: No such file or directory
    

    I am wondering if this error may be due to my hardware. I am using a Jetston TX2 (aarch64 architecture for 64-bit ARMv8) running 64-bit Ubuntu 16.04. I noticed that the NCSDK only installs API library files for the armv7l architecture for 32-bit ARM. I don't have a lot of experience with ARM, but I've read that 64-bit ARMv8 systems should be back-compatible with code for 32-bit ARMv7, so I was hoping the NCSDK API would still work.

    I can compile the NCSDK on the Jetson just fine (after several deviations from the install script to install Tensorflow without using pip, etc.). However, it errors out when I try to compile the examples. I am able to compile and run the examples on my x86 64-bit Ubuntu 16.04 laptop.

    So is the NCSDK API compatible with the aarch64 architecture for 64-bit ARM? Or could this error be a different issue?

  • @georgievm_cms Thanks! I'll try the suggestions in that thread.

Sign In or Register to comment.