frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

NCS2 with NanoPi-M4

Hello,

I am Using NanoPi-m4 with SoC: Rockchip RK3399
CPU: big.LITTLE,Dual-Core Cortex-A72(up to 2.0GHz) + Quad-Core Cortex-A53(up to 1.5GHz)
GPU: Mali-T864 GPU,supports OpenGL ES1.1/2.0/3.0/3.1, OpenVG1.1, OpenCL, DX11, and AFBC
VPU: 4K VP9 and 4K 10bits H265/H264 60fps decoding, Dual VOP, etc
with FriendlyDesktop (Ubuntu core) 18.04 64

architecture: arm (aarch64)

I have issues in installing ncsdk2 latest version v2.10.
ERROR: opt/movidius/ncsdk/aarch64/tk no such file or directory.

I used this repository https://github.com/markjay4k/ncsdk-aarch64 to install ncsdk but it was version 1.12 it worked well but when I modified it to install version 2.10 it had issues in shared libraries

Is there an incompatibility between ncsdk2 and nanopi?

Comments

  • 1 Comment sorted by Votes Date Added
  • Hi @Ahmed_Gaber

    We have not validated the NanoPi-m4 with the Neural Compute SDK 1 or 2. The repository above modified the installation for the NCSDK 1, I am not familiar with the changes made.

    Currently we only support X86 and Raspberry Pi 3+ running Raspbian.
    Please share your results with the community if you get a successful install.

    Regards,
    Jesus

This discussion has been closed.