frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Troubleshooting

When i was trying to setup and work with Neural compute stick2 I am getting this Error:
"[ ERROR ] Can not init USB device: NC_DEVICE_NOT_FOUND"
When i do the Troubleshooting the above Error by following command "sudo udevadm test /dev/sda". I am getting one more Issue
like "unable to open device '/sys/dev/sda'
Unload module index
Unloaded link configuration context."

I would appreciate if anyone could provide any suggestion to solve this issue.

Thanks
Sudheer

Comments

  • 7 Comments sorted by Votes Date Added
  • Hi @sudheer

    Which SDK are you using? You will need to use the OpenVINO toolkit with the Intel Neural Compute Stick 2. The Neural Compute SDK only supports the original Neural Compute Stick. Take a look at the Getting Started Guide.

    Could you copy/paste the output of lsusb? If you can also please provide additional details about your setup (OS, Virtual Machine?, Powered USB Hub?, etc.).

    Regards,
    Jesus

  • @Jesus_at_Intel

    Here is my lsusb:
    sudheer@sudheer:/intel/computer_vision_sdk/deployment_tools/demo$ lsusb
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 019: ID 03e7:2485
    Bus 001 Device 018: ID 80ee:0021 VirtualBox USB Tablet
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    1. OS : Ubuntu 16.04lts
    2. virtual box: Oracle vm virtual box manager
    3. powered USB Hub: I am using "Robotick" usb3 connector(I checked with the pendrive is showing the contenct) it is a single connector provision
    4. suggest me suitable powered USB hub
  • Hi @sudheer

    Your Intel Neural Compute Stick 2 is being detected by the virtual machine. Could you confirm you have setup the filters properly and have installed the virtualbox extension pack. Other users have also ran into similar issues when using Virtualbox. I recommend updating to Virtualbox 6.0.4 if you haven't already.

    Your power USB hub should be fine as the device is being detected.

    • Which command are you executing when you receive the error?
    • What version of the OpenVINO toolkit are you using?

    Regards,
    Jesus

  • Hi @Jesus_at_Intel,

    I am confirming set up the filters https://drive.google.com/drive/folders/1191sKj8L29RGgTbEK4azMQuQNRJeD8WV?usp=sharing
    Followed windows setup using the link https://software.intel.com/en-us/articles/OpenVINO-Install-Windows with optional steps also I did.(https://drive.google.com/drive/folders/1191sKj8L29RGgTbEK4azMQuQNRJeD8WV?usp=sharing)
    Followed linux setup using the link https://software.intel.com/en-us/articles/OpenVINO-Install-Linux with optional steps also I did.(https://drive.google.com/drive/folders/1191sKj8L29RGgTbEK4azMQuQNRJeD8WV?usp=sharing)

    I am using the below spec:
    Virtual Box : VirtualBox-6.0.4-128413-OSX.dmg
    Virtual Box Extension Pack : Oracle_VM_VirtualBox_Extension_Pack-6.0.4.vbox-extpack
    windows ISO: Win10_1809Oct_English_x64.iso from Microsoft official website(https://www.microsoft.com/en-us/software-download/windows10ISO)
    Ubuntu ISO : ubuntu-16.04.5-desktop-amd64.iso

    Movidius INF & HDDL Bus INF also successfully done.

    when I was running the command "./demo_security_barrier_camera.sh" under /opt/intel/computer_version_sdk_2018.5.445/deployment_tool/demo/ getting the inference output correctly. Note: with/without connecting of Neural compute stick2 i am getting this. But, when i give the command like "./demo_security_barrier_camera.sh -d MYRIAD"
    I am getting the issue like "cannot init USB device NC_DEVICE_NOT_FOUND"

    In Windows, I am running "demo_security_barrier_camera.bat -d MYRIAD" I am getting the issue "cannot init USB device NC_DEVICE_NOT_FOUND"

    From Both Windows & Linux Machines, I am getting the same issue.

    Please see the drive images you may get better clarity. Please do the needful to solve this issue with the virtual boxes.

    Thanks
    Sudheer

  • Hi @sudheer

    There is an issue with your hardware setup or VM configuration, make sure the VM is properly setting up the USB 3.0 device. From the Ubuntu VM, execute lsusb and copy/paste the output here. I will also recommend trying with a powered USB hub.

    When you run the sample without the-d MYRIAD it on the CPU instead of the Neural Compute Stick. Since the VM is not detecting the device, it will fail when using the -d MYRIAD but will run properly with it runs on the CPU.

    Regards,
    Jesus

  • Having the exact same issue on my my iMac. I am plugging the NCS2 directly to the omputer, and get the same error message.

    Any ideas on how to fix ?

    I am using the same version of Virtualbox, and Ubuntu. All settings, including rules have been carefully installed.

    Everytime that I try to run the demo, I get the same message :
    ```[ INFO ] Loading model to the plugin
    E: [ncAPI] [ 858711] ncDeviceOpen:870 failed to find device

    [ ERROR ] Can not init USB device: NC_DEVICE_NOT_FOUND
    Error on or near line 235; exiting with status 1
    ```

    When i do the Troubleshooting the above Error by following command "sudo udevadm test /dev/sda". I am getting one more Issue
    like "unable to open device '/sys/dev/sda'
    Unload module index
    Unloaded link configuration context."

    Help would be appreciated... there are lots of people having this issue, and no sollution.

    Thanks !

  • Hi @beinir

    The issue is similar, however, your setup may be a bit different.

    Regards,
    Jesus

Sign In or Register to comment.