frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Unable to run Image Classification Examples

Hi,

I have followed the installation steps for NCS 2. When trying to run classification example (step 4), I get the following error:

Run Inference Engine classification sample

Run ./classification_sample -d MYRIAD -i /intel/computer_vision_sdk_2018.4.420/deployment_tools/demo/../demo/car.png -m /home/sudheer/openvino_models/ir/squeezenet1.1/FP16/squeezenet1.1.xml

[ INFO ] InferenceEngine:
API version ............ 1.4
Build .................. 17328
[ INFO ] Parsing input parameters
[ INFO ] Files were added: 1
[ INFO ] /intel/computer_vision_sdk_2018.4.420/deployment_tools/demo/../demo/car.png
[ INFO ] Loading plugin

API version ............ 1.4
Build .................. 17328
Description ....... myriadPlugin

[ INFO ] Loading network files:
/home/sudheer/openvino_models/ir/squeezenet1.1/FP16/squeezenet1.1.xml
/home/sudheer/openvino_models/ir/squeezenet1.1/FP16/squeezenet1.1.bin
[ INFO ] Preparing input blobs
[BMP] file is not bmp type
[ WARNING ] Image /intel/computer_vision_sdk_2018.4.420/deployment_tools/demo/../demo/car.png cannot be read!
[ ERROR ] Valid input images were not found!
Error on or near line 215; exiting with status 1

Note: I tried with the below
1. product to download : Intel Distribution of OpenVino toolkit for Linux
2. version : 2018 R4
3. Customizable package & Full Package
4. tried with the both packages getting same issue

The image is in the folder so I don't know why it fails. I would appreciate if anyone could provide any suggestion to solve this issue.

Thank you,
Sudheer

Comments

  • 9 Comments sorted by Votes Date Added
  • Hi @sudheer ,

    Thanks for reaching out. Looking at the executed command I can see that there could be a typo in the path to the .png file: you have /intel/computer_vision_sdk_2018.4.420/deployment_tools/demo/../demo/car.png instead of /opt/intel/computer_vision_sdk_2018.4.420/deployment_tools/demo/../demo/car.png. Please give it a try and let me know if the problem persists.

    Regards,
    @Luis_at_Intel

  • edited February 20 Vote Up0Vote Down

    Hi @Luis_at_Intel,

    I have setup installed all the things in my customizable location not in the /opt directory

    I setup the environment for OpenVINO in the below.
    [setupvars.sh] OpenVINO environment initialized
    sudheer@sudheer:/intel/computer_vision_sdk_2018.4.420/deployment_tools/demo$

    I believe it will fetch from the above location where i saved from the first time location.

    Any how, I tried your approach also and getting the same issue

    Run Inference Engine classification sample

    Run ./classification_sample -d MYRIAD -i /opt/intel/computer_vision_sdk_2018.4.420/deployment_tools/demo/../demo/car.png -m /home/sudheer/openvino_models/ir/squeezenet1.1/FP16/squeezenet1.1.xml

    [ INFO ] InferenceEngine:
    API version ............ 1.4
    Build .................. 17328
    [ INFO ] Parsing input parameters
    [ INFO ] Files were added: 1
    [ INFO ] /opt/intel/computer_vision_sdk_2018.4.420/deployment_tools/demo/../demo/car.png
    [ INFO ] Loading plugin

    API version ............ 1.4
    Build .................. 17328
    Description ....... myriadPlugin

    [ INFO ] Loading network files:
    /home/sudheer/openvino_models/ir/squeezenet1.1/FP16/squeezenet1.1.xml
    /home/sudheer/openvino_models/ir/squeezenet1.1/FP16/squeezenet1.1.bin
    [ INFO ] Preparing input blobs
    [BMP] file is not bmp type
    [ WARNING ] Image/opt/intel/computer_vision_sdk_2018.4.420/deployment_tools/demo/../demo/car.png cannot be read!
    [ ERROR ] Valid input images were not found!
    Error on or near line 215; exiting with status 1

    Any suggestion?

    Thanks
    Sudheer

  • Hi @sudheer ,

    I have tested both the latest OpenVINO toolkit release (R5.0.1) and also R4 with an Ubuntu host machine. For me both versions run as expected and I have them installed on the default location /opt/intel/computer-vision-sdk, could you print the working directory where the car.png file is located? Also please let me know the path of your installation so I can attempt to install it and reproduce, I am curious if the problem is related to the install path or where the .png file is located. Also what is your Host OS? Fresh install of Ubuntu or CentOS ? Are you running on a VM? Please let me know so we can help you resolve this issue.

    @Luis_at_Intel

  • Hi @Luis_at_Intel,

    I am Using MacBook Pro(Mac OS high Sierra,10.13.6)

    I am confirming set up the filters https://drive.google.com/drive/folders/1191sKj8L29RGgTbEK4azMQuQNRJeD8WV?usp=sharing
    Followed windows setup using the link https://software.intel.com/en-us/articles/OpenVINO-Install-Windows with optional steps also I did.(https://drive.google.com/drive/folders/1191sKj8L29RGgTbEK4azMQuQNRJeD8WV?usp=sharing)
    Followed linux setup using the link https://software.intel.com/en-us/articles/OpenVINO-Install-Linux with optional steps also I did.(https://drive.google.com/drive/folders/1191sKj8L29RGgTbEK4azMQuQNRJeD8WV?usp=sharing)

    I am using the below spec:
    Virtual Box : VirtualBox-6.0.4-128413-OSX.dmg
    Virtual Box Extension Pack : Oracle_VM_VirtualBox_Extension_Pack-6.0.4.vbox-extpack
    windows ISO: Win10_1809Oct_English_x64.iso from Microsoft official website(https://www.microsoft.com/en-us/software-download/windows10ISO)
    Ubuntu ISO : ubuntu-16.04.5-desktop-amd64.iso

    Movidius INF & HDDL Bus INF also successfully done.

    when I was running the command "./demo_security_barrier_camera.sh" under /opt/intel/computer_version_sdk_2018.5.445/deployment_tool/demo/ getting the inference output correctly. Note: with/without connecting of Neural compute stick2 i am getting this. But, when i give the command like "./demo_security_barrier_camera.sh -d MYRIAD"
    I am getting the issue like "cannot init USB device NC_DEVICE_NOT_FOUND"

    In Windows, I am running "demo_security_barrier_camera.bat -d MYRIAD" I am getting the issue "cannot init USB device NC_DEVICE_NOT_FOUND"

    From Both Windows & Linux Machines, I am getting the same issue.

    Please see the drive images you may get better clarity. Please do the needful to solve this issue with the virtual boxes.

    Thanks
    Sudheer

  • Hi @sudheer ,

    Thanks for the information, I tested on a MacBook Pro (Mid 2012, MacOS High Sierra v10.13.6) and it took me a few tries to get the NCS2 detected by the VM (I was getting the same error message as you).
    I used VirtualBox6.0.4 r128413 with Extension Pack 6.0.4r128413, I have Ubuntu 16.04 running as the VM and I installed OpenVINO Toolkit R5.0.1. Below are the filters that I have used and it seems to work for both NCS and NCS2.

    Enable USB Controller [X]
    USB 3.0 (xHCI) Controller [X]
    USB Device Filters:
    1. Name: 03e7
    Vendor ID: 03e7
    </all other fields blank/>
    2. Name: 040e
    Vendor ID: 040e
    </all other fields blank/>

    I am going to try it on a Windows 10 VM, please give it a try to the suggestions above for your Ubuntu VM and let me know your results.

    Regards,
    @Luis_at_Intel

  • Hi @sudheer ,

    [UPDATE]
    I have tried OpenVINO Toolkit R5.0.1 also on a Windows 10 VM and I encountered a similar behavior as you (aka NC_DEVICE_NOT_FOUND error), even with the driver installed it still didn't work for me. But after adding the same filters as I mentioned for the Ubuntu 16.04 VM (comment above), both demos (demo_security_barrier_camera.bat and demo_squeezenet_download_convert_run.bat) run just fine. The NCS2 plugin is detected and the program executes as expected.

    Please try to add those filters to the Windows 10 VM and let me know your results, hope this helps resolve your issue!

    Regards,
    @Luis_at_Intel

  • @Luis_at_Intel ,

    Thanks, Luis, It's worked for me for both the windows and ubuntu.

  • @Luis_at_Intel ,

    what is the steps i can follow to run tensorflow object detection SSD mobilenet model on NCS2?

  • @sudheer ,
    I am glad our suggestions helped resolve your problem. As far as your other question, I'd suggest to open a new thread and we will answer there, but for now you can take a look at the pre-trained models here https://software.intel.com/en-us/openvino-toolkit/documentation/pretrained-models and see if you find what you are looking for.

    Regards,
    @Luis_at_Intel

This discussion has been closed.