frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Can not make ncsdk in api-only mode in pi(3b+).

Tutorial following:https://movidius.github.io/blog/ncs-apps-on-rpi/
At the compilation step, when running make from ncsdk/api/src, this message was shown(It was the only message):

NCSDK FW successfully installed

But in the next step,when trying to install using make install, this error was thrown:

Makefile:44: recipe for target 'get_mvcmd' failed
make: *** [get_mvcmd] Interrupt

So I tried compiling it many times, each time resulting in this error:

Error downloading . Will try to restore existing firmware
Error restoring old firmware - directory ./mvnc.old doesn't exist. Will exit
Makefile:44: recipe for target 'get_mvcmd' failed
make: *** [get_mvcmd] Error 1

Tried uninstalling using make uninstall( though not mentioned in the tutorial ). But the same error as above was the result.
Does anyone has an idea about where I have gone wrong?

Comments

  • 2 Comments sorted by Votes Date Added
  • Hi @sreerag_ibtl
    A couple questions for you:
    1. Did you make sure to install all Debian and Python dependencies from Step 2 of the installation guide?
    2. Are you in the correct directory when installing?
    3. Did you use the command sudo make install?

    Regards,
    Sahira

  • Thanks @Sahira_at_Intel for your reply. I tried it again and the installation was successful this time. Don't know why it failed the first time, though all the instructions were followed correctly. ( This is the second time this magic is happening to me. Other one was when installing OpenCV.) :smile:

This discussion has been closed.