frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Issue with NCS while running "make examples" or hello_ncs

Hello,
I've recently acquired a NCS and have yet to manage finishing the setup:

  1. System specifications : Oracle VM VirtualBox - Ubuntu Desktop 16.04 ; fresh install, 3GB of RAM ( host: i5-4440@3,1GHz and 12GB of ram running Windows 10 )
  2. NCSDK version i believe it's 2.08 ( I've followed the github instructions for both the VM ( https://movidius.github.io/ncsdk/vm_config.html ) and the instalation ( https://movidius.github.io/ncsdk/install.html ) )
  3. Python version Python 3.5.2

after running make install, everything seems to go OK

when running make examples, I can hear the "usb device disconnected" sound that windows plays, and then it crashes with error 7. after looking at a couple of pages on this forum, I've found a post that said that I should check if the usb can be seen by the VM
I've taken a couple of screenshots that can be found here: https://drive.google.com/drive/folders/16o6T7LX2srP18Dmv_7ymyQJynOylsaZE
general explanation of photos:
boot-up.png has the output of dmesg and lsusb in relation to the NCS ( we can see it )
dmesg.png has the output of dmesg after running make examples ( the device just disconnects )
hello_ncs.png has the output of lsusb before running hello_ncs and the formers output ( the output of dmesg is similar to the previous one )

Any help would be of great use and greatly appreciated.

If I need to provide more info, I am willing to do so.

Thank you kindly,
Laur.

Comments

  • 5 Comments sorted by Votes Date Added
  • Hello Laur. Have you found a solution? If so, please post. I had the same problem.

  • Hello azlefty,
    I haven’t tried anything since posting. My next try would include a prpper ubuntu install, but that won’t happen until next week, since I haven’t got the hw available.

    Best regards,
    Laur

  • After doing a full install of Ubuntu, the examples were compiled without errors, and I was able to run a couple of them.
    Now, the fun begins!

    Best regards,
    Laur

  • @laupetre I have the EXACT same problem. I hear my virtualbox disconnecting the USB when I run "make examples" or "python3 hello_ncs.py". Any specific solutions?

  • I just posted a suggestion on another thread to try. Let me know if this helps!

    Did you setup the USB filters in the VirtualBox machine settings? I found that I also had to install the VirtualBox Extension Pack on Virtualbox. Once the extension pack was installed, I also loaded guest additions to the guest machine.

    1. Start the Guest Machine
    2. Devices -> Insert Guest Additions CD image...
    3. Follow the prompt instructions
    4. Reboot the Guest Machine

    Regards,
    Jesus

This discussion has been closed.